Delayed account verifications in South Africa
Incident Report for Luno
Resolved
The issue with our third-party provider affecting account verifications in South Africa has been fully resolved.

Services are now operating normally, and we will continue to monitor to maintain stability.
Posted Nov 13, 2024 - 06:00 UTC
Monitoring
We have resolved an earlier issue with one of our third-party providers that was causing delays in account verifications in South Africa.

Services have now recovered, and we are closely monitoring to ensure stability.
Posted Nov 12, 2024 - 14:36 UTC
Identified
We have identified an issue with one of our third-party providers that may be causing account verifications in South Africa to be delayed.

We are working closely with them to get this resolved.
Posted Nov 12, 2024 - 09:48 UTC