Customers unable to add new accounts via Stitch - South Africa

Incident Report for Luno

Resolved

We are no longer seeing any errors with linking new accounts and can confirm that this incident is resolved.
Posted May 22, 2023 - 09:09 UTC

Monitoring

A fix has been implemented and all new accounts being added through Stitch will be linked successfully
Posted May 22, 2023 - 08:55 UTC

Identified

The issue has been identified and our engineers are working on a fix.
Posted May 22, 2023 - 08:46 UTC

Investigating

We are currently investigating an issue that is preventing South African customers from adding new bank accounts to their Luno accounts. We will provide updates shortly.
Posted May 22, 2023 - 08:34 UTC