Slow FPX Deposits in Malaysia
Incident Report for Luno
Resolved
Update:

We have implemented a fix and there should be no further delays with FPX instant deposits.

We appreciate your understanding in this matter.
Posted Nov 12, 2024 - 13:31 UTC
Update
Update:

Customers who use FPX instant deposit method may experience delayed deposits.

We are working with our third-party payment provider to resolve this issue ASAP.

In the meantime, please make use of alternative deposit methods.

We apologise for any inconvenience caused.
Posted Nov 12, 2024 - 09:00 UTC
Identified
Update:

Customers who use FPX instant deposit method may experience delayed deposits.

We are working with our third-party payment provider to resolve this issue ASAP.

In the meantime, please make use of alternative deposit methods.

We apologise for any inconvenience caused.
Posted Nov 12, 2024 - 09:00 UTC
Investigating
We're aware of a delay with FPX deposits and our team is currently investigating it. We hope to have this resolved soon.
Posted Nov 12, 2024 - 08:35 UTC