Delayed express withdrawals in South Africa

Incident Report for Luno

Resolved

All delayed express withdrawals have been processed.

Express withdrawals are working as normal

We apologise for any inconvenience caused.
Posted Mar 24, 2025 - 06:29 UTC

Identified

We are experiencing temporary delays with express withdrawals due to unexpected downtime with our banking partner.

Normal EFTs remain unaffected

Please rest assured that we are in direct communication with the bank and are actively working to resolve the issue as quickly as possible.

We will provide updates as soon as we have more information.
Posted Mar 23, 2025 - 21:16 UTC