The issue affecting account verifications in Indonesia has been resolved. We are no longer receiving errors from our third-party verification provider, and account verifications are now being processed normally.
Thank you for your patience while we worked through this.
Posted Jan 05, 2026 - 07:31 UTC
Monitoring
Account verifications are being processed as expected.
We will continue to monitor the situation. Thank you for your patience.
Posted Jan 04, 2026 - 17:31 UTC
Identified
Users in Indonesia may experience delays in account verification due to downtime with our third-party verification provider. We are actively monitoring the situation.