Delayed Withdrawals in Uganda
Incident Report for Luno
Resolved
This has been resolved and all withdrawals are processing as normal.
Posted May 13, 2023 - 08:42 UTC
Identified
We are currently experiencing an issue due to third party downtime which is causing delayed withdrawals for customers.

We are working with the third party to restore service as soon as possible and will provide further updates here.
Posted May 12, 2023 - 10:51 UTC