Delayed withdrawals in Nigeria
Incident Report for
Luno
Monitoring
The backlog of withdrawals has been successfully cleared. All withdrawal transactions are now being processed.
We continue to actively monitor the situation and are in close contact with our payment provider to ensure the ongoing stability of our services.
Thank you for your patience and understanding.
Posted
Jul
11
,
2025
-
17:39
UTC
Identified
We are experiencing delayed withdrawals due to intermittent downtime with our payment provider.
We are in contact with them and working to resolve this as quickly as possible.
We will provide updates as soon as possible.
Posted
Jul
11
,
2025
-
13:46
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed withdrawals in Nigeria
via . You'll receive .