Help Centre Unavailable

Incident Report for Luno

Resolved

We have resolved the issue and the Help Centre is now functioning as normal.
Posted Nov 24, 2021 - 14:30 UTC

Identified

We have identified an issue with our Help Centre which is currently unavailable.

Our team is investigating and working on a fix as a priority.
Posted Nov 24, 2021 - 14:24 UTC