Banking details not displayed
Incident Report for Luno
Resolved
The issue with displaying bank details has been resolved.
Posted May 30, 2022 - 14:28 UTC
Monitoring
A fix has been implemented for this and our banking details should now be visible.

We will continue to monitor for further issues.

Apologise for any inconvenience.
Posted May 30, 2022 - 09:52 UTC
Investigating
We are currently investigating an issue on iOS which is causing customers not to see our bank details when going through the deposit flow in some regions.

Our engineers are investigating this issue as a priority. Updates to follow.
Posted May 30, 2022 - 09:13 UTC