Exchange Pairs are unavailable in the EU
Incident Report for
Luno
Resolved
This incident has been resolved.
Posted
Sep
03
,
2025
-
07:12
UTC
Identified
The Exchange pairs in the EU are not available for Customers. Our team is working to resolve the issue and apologise for any inconvenienced caused.
Posted
Aug
29
,
2025
-
09:41
UTC
×
Subscribe to Incident
Subscribe to updates for
Exchange Pairs are unavailable in the EU
via . You'll receive .