Help Centre Unavailable
Incident Report for
Luno
Resolved
The help centre is running as normal, customers should not see any further errors.
We appreciate your patience and understanding in this matter.
Posted
Feb
28
,
2025
-
11:40
UTC
Identified
We are currently experiencing an issue causing the help centre to be unavailable, customers may receive an error when trying to access our help centre
We are working on a fix as a priority.
Updates to follow
Posted
Feb
28
,
2025
-
11:28
UTC
×
Subscribe to Incident
Subscribe to updates for
Help Centre Unavailable
via . You'll receive .