Slow Bitcoin transactions
Incident Report for Luno
Resolved
Bitcoin transaction times have returned to normal, we'll continue to monitor for any further anomalies.
Posted Sep 12, 2020 - 04:30 UTC
Monitoring
Bitcoin sends from Luno have normalised however fees remain quite high as a result of congestion on the Bitcoin Blockchain.

We'll continue to monitor closely and update you if this changes.
Posted Sep 11, 2020 - 21:51 UTC
Identified
We've identified a backlog of Bitcoin transactions, this is unfortunately due to congestion

This is out of Luno's control, thankfully this usually clears quite quickly. We'll keep a close eye on transactions.
Posted Sep 11, 2020 - 19:00 UTC