Delayed Bitcoin (BTC) sends
Incident Report for Luno
Resolved
The issue has been resolved and Bitcoin (BTC) sends have returned to normal.
Posted Sep 18, 2021 - 08:28 UTC
Monitoring
We are monitoring an issue causing a delay for all Bitcoin (BTC) sends. We're hoping to see this resolved soon and are working on this as a priority. BTC receives are unaffected and are performing as normal.
Posted Sep 17, 2021 - 21:00 UTC
This incident affected: Crypto sends and receives (BTC).