Delayed price updates for LINK pairs
Incident Report for Luno
Resolved
This has been resolved and price updates are working as expected.
Posted Aug 02, 2022 - 12:41 UTC
Investigating
We are investigating an issue that may be causing delays in price updates for certain LINK pairs.

We are working on this as a priority
Posted Aug 02, 2022 - 12:19 UTC