Delayed Bank Transfer withdrawal in Nigeria
Incident Report for
Luno
Resolved
The issue has been resolved, and everything is now functioning normally.
Thank you for your understanding and patience.
Posted
Aug
27
,
2024
-
09:04
UTC
Update
Our payment provider has confirmed the issue has been fixed and is currently processing any withdrawals that were delayed.
Posted
Aug
27
,
2024
-
07:08
UTC
Monitoring
We are actively monitoring this issue to ensure everything is working as expected.
Posted
Aug
26
,
2024
-
14:32
UTC
Identified
Customers will experience delays with bank transfer withdrawals and voucher withdrawals.
Unfortunately, this issue is with our payment provider. We are working closely with them to resolve this as soon as possible.
We appreciate your understanding and apologise for any inconvenience this may cause.
Posted
Aug
26
,
2024
-
12:43
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Bank Transfer withdrawal in Nigeria
via . You'll receive .