Delayed bank withdrawals in Malaysia.

Incident Report for Luno

Resolved

Withdrawals are now being processed as scheduled. Thank you
Posted Nov 11, 2025 - 00:00 UTC

Monitoring

We experienced a temporary delay with processing Malaysian withdrawals requested on November 10, 2025, between 12:00 PM and 3:45 PM.

Any withdrawals submitted during this time are expected to reflect by Tuesday at 11:00 AM.

You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934

We apologise for the inconvenience caused.
Posted Nov 10, 2025 - 11:10 UTC