Instant EFT via PayU unavailable
Incident Report for Luno
Resolved
PayU has concluded maintenance and deposits are processed successfully.

Thank you for your patience.
Posted Oct 01, 2020 - 08:49 UTC
Investigating
Due to unplanned maintenance planned by our 3rd party provider PayU, deposits via Instant EFT is currently unavailable to customers.

We're working with the provider to have this re-enabled as soon as possible.

Updates to follow.
Posted Sep 30, 2020 - 22:28 UTC