Planned maintenance may potentially impact Express withdrawals in South Africa

Incident Report for Luno

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 07:37 UTC

Investigating

We have been informed that scheduled maintenance is anticipated on Monday, August 18, 2025, between 00:00 and 05:00. This maintenance may cause potential downtime.

Consequently, express withdrawals may be delayed due to internal bank processes, which are beyond our control.
Posted Aug 15, 2025 - 14:10 UTC