Slow account verifications in Indonesia
Incident Report for Luno
Resolved
No further verification delays as of 16:00 UTC, thanks for your patience.
Posted Nov 15, 2023 - 17:37 UTC
Monitoring
This has been resolved, we're monitoring for any additional delays or errors.
Posted Nov 15, 2023 - 16:09 UTC
Investigating
We're investigating an issue causing account verifications to be slower than normal.
Updates to follow.
Posted Nov 15, 2023 - 14:36 UTC