Unable to send Cryptocurrency

Incident Report for Luno

Resolved

Update:

We are no longer seeing any errors with regards to sends.

Sends should be working as normal.

We appreciate your patience and understanding in this matter.
Posted May 18, 2026 - 11:40 UTC

Identified

We have identified the root cause of this issue.

Our team is working to get the fix out ASAP.

Customers will get a message letting them know we could not complete the send.

Updates to follow
Posted May 18, 2026 - 11:23 UTC

Investigating

We are investigating an issue causing an issue when customers attempt to initiate cryptocurrency sends.

Customers will get a message letting them know we could not complete the send.

We are working on this as a priority.

Updates to follow
Posted May 18, 2026 - 11:15 UTC