Slow withdrawals in Nigeria
Incident Report for
Luno
Resolved
Withdrawals are being processed as normal.
Posted
Jun
10
,
2024
-
07:41
UTC
Monitoring
The vendor has informed us that this has been resolved yesterday, we're monitoring for further impact.
Posted
Jun
07
,
2024
-
10:57
UTC
Identified
Withdrawals in withdrawals are being processed slower than usual due to downtime with a vendor.
Updates to follow.
Posted
Jun
06
,
2024
-
12:59
UTC
×
Subscribe to Incident
Subscribe to updates for
Slow withdrawals in Nigeria
via . You'll receive .