Delayed account verification
Incident Report for
Luno
Resolved
There are no further account verification delays.
We apologize for any inconvenience caused.
Thank you for being so patient during this time
Posted
Aug
28
,
2024
-
12:42
UTC
Monitoring
A fix has been implemented, we're monitoring the results.
Posted
Aug
28
,
2024
-
10:40
UTC
Identified
Customers wanting to verify their account may see a slower-than-normal turnaround time.
Our team is working hard to fix this issue.
We apologize for any inconvenience caused.
Posted
Aug
28
,
2024
-
10:18
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed account verification
via . You'll receive .