Delayed bank withdrawal in Indonesia

Incident Report for Luno

Resolved

Withdrawals are now being processed as scheduled. Thank you
Posted May 18, 2022 - 03:54 UTC

Identified

Certain withdrawals in Indonesia will not be processed from 28th April until 8th May 2022 due to the public holiday. Unfortunately, banks do not process such withdrawals over weekends or public holidays.

These withdrawals will be processed on 9th May 2022.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Apr 27, 2022 - 09:44 UTC