Our payment provider has confirmed that they successfully cleared the backlog, and deposits are now back to normal. We will continue to monitor for any further issues.
Thank you for your patience and understanding during this time. We apologise for any inconvenience caused.
Posted Dec 06, 2024 - 14:19 UTC
Update
Update:
We have identified this issue may cause delays for deposits and withdrawals via bank transfers due to issues with one of our third-party providers.
We are working closely with them to get this resolved.
We apologise for any inconvenience caused and appreciate your patience.
Posted Dec 04, 2024 - 07:18 UTC
Identified
Customers will experience delays with deposits via bank transfer.
Unfortunately, this issue is with our payment provider, we are working closely with them to resolve this as soon as possible.
We appreciate your understanding and apologize for any inconvenience this may cause.