Deposits and withdrawals service interruption in Australia
Incident Report for Luno
Resolved
Deposits and withdrawals are now being processed as scheduled. Thank you
Posted Aug 08, 2022 - 02:50 UTC
Identified
Please be advised that our payments provider will be undergoing a service maintenance on 7th August 2022 which may affect your deposits and withdrawals.

Appreciate if you could plan and make deposits before/after the following downtime:
Sunday, 7th August 2022 12.00am - 10.00am AEST

All services will resume to normal after the maintenance is complete. We are very sorry for the inconvenience.

Thank you for your understanding.
Posted Aug 05, 2022 - 09:55 UTC