Unable to Send Crypto via Web in Malaysia
Incident Report for
Luno
Resolved
This incident has been resolved.
Posted
Sep
04
,
2025
-
09:27
UTC
Identified
Customers in Malaysia are unable to send Crypto via Web. Customers can still use the app for Sends. Our team is woking to resolve the issue. We apologise for inconvenienced caused.
Posted
Sep
02
,
2025
-
07:33
UTC
×
Subscribe to Incident
Subscribe to updates for
Unable to Send Crypto via Web in Malaysia
via . You'll receive .