Linking new bank cards and deposits in South Africa

Incident Report for Luno

Resolved

No further impact since our last update, thanks for your patience.
Posted Feb 18, 2025 - 13:51 UTC

Monitoring

We're seeing better results, we're monitoring for any further errors.
Posted Feb 18, 2025 - 11:53 UTC

Identified

Customers may see slower than usual responses through the flow of linking a new bank card or deposits.

Some customers may see a "something went wrong" when trying to deposit.
Posted Feb 18, 2025 - 11:30 UTC