Delayed bank withdrawals in Europe
Incident Report for Luno
Resolved
Withdrawals made prior to our correction have now been processed successfully. All withdrawals are being processed as normal.
We apologise for any inconvenience.
Posted May 11, 2022 - 12:13 UTC
Monitoring
A fix has been implemented and new withdrawals are being processed successfully however some withdrawals made prior to the correction remain affected. Our team will work to clear the backlog of those withdrawals.
Posted May 09, 2022 - 17:32 UTC
Identified
There may be temporary delays with EUR and GBP withdrawal requests. Our team is aware and has identified the issue and is working on a fix. Updates to follow.
Posted May 09, 2022 - 16:56 UTC