Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted May 31, 2021 - 03:47 UTC
Identified
Certain withdrawals in Indonesia will not be processed on 26th May 2021 due to the public holiday. Unfortunately, banks do not process withdrawals over weekends or public holidays.

Such withdrawals will be processed on 27th May 2021.

For more information on this, please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 24, 2021 - 10:55 UTC