Incomplete FTM wallet graph information
Incident Report for
Luno
Resolved
We are no longer seeing an incomplete FTM graph on their Luno wallet.
We appreciate your understanding in this matter.
Posted
Aug
26
,
2025
-
09:52
UTC
Identified
We have identified an issue where customers will see an incomplete FTM graph on their Luno wallet.
Our team is working to fix this issue.
We appreciate your understanding in this matter.
Posted
Aug
26
,
2025
-
09:12
UTC
×
Subscribe to Incident
Subscribe to updates for
Incomplete FTM wallet graph information
via . You'll receive .