Intermittent issues with the exchange view on the home screen
Incident Report for Luno
Resolved
A fix has been implemented for the intermittent problems with the home screen experienced by some customers.

We are not seeing any further anomalies.

Thank you for your patience in this regard.
Posted May 26, 2023 - 11:47 UTC
Investigating
We are currently investigating an issue that is causing intermittent problems when making use of the exchange view on the home screen page.

The exchange view may be replaced by the default view of the home screen for some customers.

We are looking into this as a matter of priority and we will provide updates as they become available.
Posted May 26, 2023 - 11:11 UTC