Delayed withdrawals and deposits in South Africa
Incident Report for
Luno
Resolved
We have pushed out a fix for this and have cleared the backlog, all withdrawals and deposits are processing as normal.
We apologise for any inconvinience caused.
Posted
Nov
29
,
2023
-
14:33
UTC
Update
We are currently investigating an issue causing delays with withdrawals and deposits in South Africa.
We are working on a fix as a priority and will provide updates as soon as we can.
Posted
Nov
29
,
2023
-
11:38
UTC
Investigating
We are currently investigating an issue causing delays with withdrawals in South Africa.
We are working on a fix as a priority and will provide updates as soon as we can.
Posted
Nov
29
,
2023
-
11:05
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed withdrawals and deposits in South Africa
via . You'll receive .