Slow support and account verification response times in Malaysia
Incident Report for Luno
Resolved
Response times have returned to normal, thanks for your patience.
Posted Jun 04, 2021 - 08:11 UTC
Update
Unfortunately, the backlog we’re working through has increased, resulting in slower than expected turnaround times from us. If you’ve submitted a conversation or identification documents after 12 May 2021, it may take up to 2 weeks for us to get back to you.

Please browse our Help Centre at luno.com/help for quick answers to your questions. Thanks for bearing with us.
Posted May 18, 2021 - 11:53 UTC
Identified
We’re currently experiencing an extremely high number of incoming queries, and we’re working through the backlog as fast as we can.

You can expect longer than normal response times. We’re sorry for the delay and we’ll do our best to get back to you within 7 working days.

Thanks so much for bearing with us.
Posted May 12, 2021 - 09:59 UTC