Exchange Trades and Balance Update Delays

Incident Report for Luno

Resolved

Orders are now executing on the exchange. Issue resolved.
Posted Jun 05, 2026 - 21:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 05, 2026 - 20:07 UTC

Identified

We are currently experiencing an issue affecting the Luno exchange.

Luno customers using the exchange and using Luno API will experience delays with their trade execution and balance updates if trades are executed.
Posted Jun 05, 2026 - 19:55 UTC