Delayed bank withdrawals in UK
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jun 17, 2021 - 06:54 UTC
Identified
There may be temporary delays with UK withdrawals requested on 15/06/2021. We’re working with the bank to see this resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Jun 15, 2021 - 13:49 UTC