Slow Bank Deposits in Malaysia
Incident Report for Luno
Resolved
Our service provider has informed that the issue has been resolved and FPX deposits should be working as usual now.
Posted Jul 14, 2021 - 09:19 UTC
Identified
Some customers are facing interruptions when making FPX deposits. Our service provider has advised this is an ongoing issue when using certain telcos/WiFi services.

If you’re facing issues, please retry making FPX deposits using an alternative Internet connection. For example, if you’re using WiFi, try using your mobile data instead. If you’re using the Luno app, please try using Luno on Web instead, as this has worked for some customers.

The FPX provider is working as fast as possible to resume normal service.
Posted Jul 14, 2021 - 07:42 UTC
Investigating
We're aware that there is a service interruption with FPX deposits. Our service provider is currently investigating the issue and we are working closely to have this issue resolved soon.
Posted Jul 14, 2021 - 05:47 UTC