Delayed withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as normal, thanks for your patience.
Posted May 07, 2024 - 08:26 UTC
Monitoring
Withdrawals are being processed as normal, we're continuing to monitor and any further delays.
Unfortunately some withdrawals are being processed after the bank cut-off. Any missed withdrawals will be processed at 08:00 SAST tomorrow morning.

Apologies for any inconvenience this may have caused.
Posted May 06, 2024 - 14:35 UTC
Identified
Some withdrawals requested after 13:00 may take longer than normal to process, we're working on a fix.
Posted May 06, 2024 - 13:29 UTC