Delayed Withdrawals In Nigeria

Incident Report for Luno

Resolved

The issue has been resolved. Thank you for your patience.
Posted May 26, 2026 - 05:54 UTC

Identified

Customers in Nigeria are experiencing delays in withdrawals due to a third-party.

We are working with the third party to resolve this as a priority.

We apologise for any inconvenience caused.
Posted May 25, 2026 - 13:32 UTC