Delayed account verification in South Africa
Incident Report for Luno
Resolved
Scheduled maintenance has been completed and account verifications are being processed as expected.

Thank you for your patience.
Posted Oct 20, 2024 - 09:25 UTC
Identified
Our verification service provider will be undergoing scheduled maintenance.

During this time, account verifications may be delayed. Once the maintenance has been completed, they will resume as normal.

Schedule

Date: 19-10-2024
Time: 17:00 to 22:00 (UTC +2)

We appreciate your understanding in this matter.
Posted Oct 18, 2024 - 06:56 UTC