Widespread power outages in Nigeria
Incident Report for Luno
Resolved
No further impact has been identified, all operations in Nigeria continue as normal.
Posted Sep 15, 2023 - 13:54 UTC
Monitoring
Account verification has been stable as of 12:27 UTC yesterday, with no other Luno services impacted.
We'll continue to monitor over the next few hours.
Posted Sep 15, 2023 - 06:29 UTC
Identified
We've seen some delays with account verification, although we cannot confirm if this is related to the power outages. Verification queues are looking normal as of 13:00 UTC.

We'll update this status page as soon as we have more information.
Posted Sep 14, 2023 - 13:05 UTC
Investigating
We're aware of the country-wide power outages affecting Nigeria.
Our team is reviewing the imapct this has on Luno customers in the region. Updates to follow.
Posted Sep 14, 2023 - 12:55 UTC