Dealyed Crypto Sends
Incident Report for
Luno
Resolved
We have resolved the issue, we are no longer experiencing any delays.
Thank you for your patience.
Posted
Oct
26
,
2025
-
18:00
UTC
Monitoring
A fix has been implemented, withdrawals are now processing successfully
We are continuing to monitor to ensure everything remains stable.
Posted
Oct
26
,
2025
-
08:10
UTC
Update
We are still seeing intermittent delayed crypto sends, we are still working on the fix as a priority.
We apologise for any inconvenience caused and thank you for your patience.
Posted
Oct
26
,
2025
-
06:13
UTC
Identified
We have identified the issue causing the delays in Crypto sends. We are working to fix the issue as a priority
We apologise for any inconvenienced caused.
Posted
Oct
26
,
2025
-
02:30
UTC
Investigating
We are currently investigating an issue that may be causing delayed crypto sends for customers.
We are treating this issue as a priority and are actively working to resolve it. We will provide an update as soon as we have more information.
Posted
Oct
26
,
2025
-
02:13
UTC
×
Subscribe to Incident
Subscribe to updates for
Dealyed Crypto Sends
via . You'll receive .