Slow Bank Deposits and Withdrawals in South Africa
Incident Report for Luno
Resolved
Deposits and withdrawals are being processed accordingly.

Thank you for your understanding.
Posted Mar 24, 2021 - 10:50 UTC
Investigating
We're aware of a delay with deposits to Standard Bank in South Africa and our team is currently investigating it. In the meantime, please make use of an alternative deposit method in your Luno wallet.

Withdrawals are being processed accordingly, however, may take some time to reflect in your Luno ZAR wallet.

We hope to have this resolved soon
Posted Mar 24, 2021 - 08:04 UTC