Delayed account recovery emails
Incident Report for Luno
Resolved
The issue affecting account recovery emails has been resolved.
Posted Jun 07, 2022 - 09:29 UTC
Investigating
We are currently experiencing an issue causing delays in account recovery emails being received by some customers.

We are looking into this as a priority.
Posted Jun 06, 2022 - 07:42 UTC