Delayed DOT Staking Withdrawals and Deposits

Incident Report for Luno

Resolved

This incident has been resolved.
Posted May 14, 2025 - 05:57 UTC

Update

There are delayed DOT Staking withdrawals and deposits. We are currently working on fixing the issue.
Posted May 14, 2025 - 02:57 UTC

Identified

There are delayed DOT Staking withdrawals and deposits. We are currently working on fixing the issue.
Posted May 14, 2025 - 01:47 UTC