Degraded service across the platform

Incident Report for Luno

Resolved

We have restored service across our platform and everything is working as expected, we apologize for any inconvinience caused.
Posted Nov 21, 2023 - 05:25 UTC

Investigating

We are currently experiencing an issue causing degraded service across our platform, we are working on resolving this as soon as possible and will provide further updates when they become available.
Posted Nov 21, 2023 - 04:59 UTC