Delayed account verifications in South Africa
Incident Report for
Luno
Resolved
This incident has been resolved. We are seeing account verification processing as normal.
We apologise for any inconvenience and thank you for your patience
Posted
Oct
02
,
2024
-
06:20
UTC
Monitoring
We are seeing improvements with our third-party provider and will continue to monitor the situation for any further issues.
We appreciate your patience.
Posted
Oct
01
,
2024
-
16:05
UTC
Identified
We have identified an issue with one of our third-party providers that is causing account verifications in South Africa to be delayed.
We are working closely with them to get this resolved.
Posted
Oct
01
,
2024
-
14:47
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed account verifications in South Africa
via . You'll receive .