Sends Unavailable for Business Customers

Incident Report for Luno

Resolved

The issue has been resolved, Sends is now working for all customers.

Thank you for your patience.
Posted Feb 20, 2026 - 16:54 UTC

Identified

We have identified an issue with Sends for Business Customers. Sends are currently disabled for some of our Business customers.

We are working on fix as a priority. Apologies for inconvenience caused.
Posted Feb 20, 2026 - 13:36 UTC