Delayed bank withdrawals and deposits in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Mar 04, 2023 - 15:01 UTC
Identified
There may be temporary delays in Nigeria with withdrawals and deposits requested on 04/03/2023
We’re working with the team to see this resolved soon.
Posted Mar 04, 2023 - 06:41 UTC