Delayed Balances For IDR Pairs

Incident Report for Luno

Resolved

This issue has now been resolved.
Posted Jun 05, 2025 - 10:47 UTC

Investigating

We are currently experiencing some technical issues which is resulting in delayed balance updates on our exchange for IDR pairs. We are actively working on resolving this and thank you for your patience. Updates will be provided as soon as this is resolved.
Posted Jun 05, 2025 - 10:23 UTC