Instant buy and sell unavailable for BTC in Uganda
Incident Report for
Luno
Resolved
Instant Buy and Sell are working as normal.
We apologize for any inconvenience caused and appreciate your patience in this matter.
Posted
Aug
29
,
2024
-
09:36
UTC
Identified
We've identified an issue where customers may not be able to buy or sell BTC using Instant Buy and Sell in Uganda.
Our team has prioritized the issue and is working on a fix.
We apologize for any inconvenience caused.
Posted
Aug
28
,
2024
-
15:28
UTC
×
Subscribe to Incident
Subscribe to updates for
Instant buy and sell unavailable for BTC in Uganda
via . You'll receive .